[Voyage-linux] [Fwd: [PATCH 01/11] hwmon: Fix negativetemperaturereadings in lm77 driver]

Punky Tse punkytse at punknix.com
Sat Feb 18 00:03:13 HKT 2006


Hi Beat,

I encounter the same problem right now - temperature reading all return 
zero values under high load.  And there are loads of i2c timeout 
messages in /var/log/kern.log.  Sounds like the kernel is busy to 
response i2c commands?

- Punky


Beat Meier wrote:
> It seems that the problem of the timeouts occures when the cpu is 
> heavy loaded.
> I do a scp to 3 clients in the background in parallel endless and the 
> problem is there.
> At least the timeouts but not the bad value of the temp.
>
> Will investigate more ...
>
> Beat
>
>> On Wed, 2006-01-18 at 06:12 +0100, Michael Renzmann wrote:
>>  
>>
>>> There have been some patches to the scx200_acb driver in the lm-sensors
>>> mailing list recently, which are said to fix some bugs in the driver.
>>> I'll give them a try (after backporting them to 2.4.x) and let you know
>>> if that helped us.
>>>   
>>
>> I'm getting old. I already applied these patches, so they didn't help us
>> with the problem.
>>
>> Could you please check what value POLL_TIMEOUT is set to in your version
>> of scx200_acb?
>>
>> Bye, Mike
>>
>>
>>  
>>
>
>
> _______________________________________________
> Voyage-linux mailing list
> Voyage-linux at list.voyage.hk
> http://list.voyage.hk/mailman/listinfo/voyage-linux


-- 
Regards,
Punky
P U N K N ! X . c o m
Technology + Lifestyle
(http://www.punknix.com)

Voyage Linux
(http://www.voyage.hk/software/voyage.html)




More information about the Voyage-linux mailing list